XRP transactions are processed longer than usual

Incident Report for Crystal Blockchain

Resolved

The incident has been resolved
Posted May 30, 2025 - 17:14 UTC

Investigating

It has been observed that the synchronization time for XRP transactions is longer than usual.
Posted May 30, 2025 - 10:57 UTC
This incident affected: Currencies (XRP).